Tips dan Trik Mengamankan Server dari Serangan DDOS

Memberikan keamanan/security ke perangkat router merupakan salah satu kewajiban yang harus dilakukan oleh system administrator jaringan. Sebagai seorang admin jaringan, selain dapat melakukan langkah konfigurasi, troubleshooting, dll maka seorang Admin jaringan juga diwajibkan untuk mengelola keamanan terhadap perangkat jaringan yang mereka miliki seperti Router, Server, dll.
Sebelum memberikan konfigurasi ke bagian Router ke Internet, maka alangkah baiknya kita dapat memberikan keamanan terlebih dahulu kepada perangkat Router. Bisa dimulai dari tahapan yang paling simple yaitu langkah mengganti username dan password Router itu sendiri, kemudian selanjutnya menutup servis yang tidak terpakai, dan mendisable Neighboor discovery.
Dan pada artikel kali ini, kita akan memberikan sedikit trik dan trik supaya menghindarkan perangkat server dari serangan DDOS dengan menggunakan Router Mikrotik. DDOS merupakan singkatan dari Distributed Denial of Service dimana pada DDOS ini adalah jenis serangan yang dilakukan dengan membanjiri secara masif lalu lintas traffic pada jaringan. Dengan adanya DDOS ini maka lalu lintas traffic pada jaringan akan menjadi penuh dan menyebabkan resource dari perangkat naik secara drastis. 
Sebagai contoh kita akan memberikan proteksi security terhadap perangkat server dari serangan DDOS.
Konfigurasi
Kita dapat mengikuti langkah-langkah pada informasi dibawah ini:
Langkah pertama, kita dapat membuat rule firewall filter dengan action drop terhadap alamat ip asal "ddoser" dengan tujuan alamat ip "ddosed".
/ip firewall filter
add chain=forward connection-state=new src-address-list=ddoser dst-address-list=ddosed action=drop
Dan langkah berikutnya , maka kita akan menangkap semua hasil koneksi "new" dan membuat chain baru yaitu "detect-ddos".
/ip firewall filter
add chain=forward connection-state=new action=jump jump-target=detect-ddos
Kemudian langkah selanjutnya kita akan membuat rule firewall sebagai berikut:

/ip firewall filter
add chain=detect-ddos dst-limit=32,32,src-and-dst-addresses/1s action=return
add chain=detect-ddos src-address=192.168.0.1 action=return

Dengan rule firewall informasi diatas, maka apabila terdapat paket new yang tidak semestinya, misalnya diatas terdapat 32 paket selama satu detik, maka firewall akan melakukan penandaan/mark terhadap alamat asal serta alamat tujuan dengan menggunakan address list. Sebagai contohnya untuk alamat IP penyerang maka akan dilakukan tindakan grouping dengan nama "ddoser", kemudian untuk alamat IP target maka akan dilakukan proses grouping dengan nama "ddosed".

/ip firewall filter
add chain=detect-ddos action=add-dst-to-address-list address-list=ddosed address-list-timeout=10m
add chain=detect-ddos action=add-src-to-address-list address-list=ddoser address-list-timeout=10m
Kesimpulan
Dengan rule diatas didapat ketika terdapat paket new yang tidak semestinya akan dilakukan proses grouping menggunakan address list dengan nama "ddosed" dan "ddoser",  dan setelah alamat IP penyerang beserta alamat IP tujuan berhasil dilacak dan ditangkap dengan menggunakan address-list maka alamat pada IP tersebut akan di drop secara otomatis oleh firewall filter yang kita buat pada tahap awal sebelumnya. Dan dengan begitu perangkat pada client seperti Server dapat terhindar dari serangan DDOS dari berbagai pihak yang tidak dikenal.

0 komentar:

Post a Comment

Translate

RSS Feed

Enter your email address:

Delivered by FeedBurner

Dark Mode

Popular Posts